Smok Vape Pen 22 is burning the hell out of my throat after one day of light usage. What am I doing wrong?

I'm on my third coil this week and I'm at my wits end. After about a day of light/moderate usage, I'm getting a burn in my throat and the flavour is awful.

The guy at the store installed my first coil and it was perfect, lasted me about five days and tasted great. I only changed it because the flavour was dying off, but I never had a single dry burn.

I changed it just like he showed me. First one tasted burnt after a day so I figured I didn't prime enough. Tried again and had the same issue the next day, so I primed the absolute shit out of the coil. Dripped in every air hole and down the centre, let it sit for almost an hour, did some priming pulls and made sure my first dozen vapes were short and fast.

And still, I'm starting to get dry, burnt inhales after less than 24 hours.

Has anyone else experienced this? Is there something I'm doing wrong with these specific coils?

TL;DR Smok 22 is burning my throat after a day of regular use even though I'm priming my coils properly.

Edit: I heard someone mention that the drip top creates a vacuum which doesn't allow the <a href="http://www.vapininthecape.com/eliquid_c_7.html”>juice to saturate, and I do notice the cotton looks bone dry when it's on but when I take it off for a couple seconds it seems to get wet. If that's the case, is that grounds to return the unit? I don't wanna have to unscrew the top every ten minutes to let <a href="http://www.vapininthecape.com/eliquid_c_7.html”>juice in. Not sure if this is the case though since it worked fine when the store employee installed it.

Edit #2: Forgot to add, the coil is 0.3ohm and the <a href="http://www.vapininthecape.com/eliquid_c_7.html”>juice I'm using is 70VG/30PG.

submitted by /u/broimgay
[link] [comments]


Fatal error: Uncaught Exception: 12: REST API is deprecated for versions v2.1 and higher (12) thrown in /home/thecapec/public_html/wp-content/plugins/seo-facebook-comments/facebook/base_facebook.php on line 1273